CRM 2016 – FieldOne – windows emulator SA.NoUserData error

 

FieldOne without mobile integration is like Hosk without CRM!

FieldOne without Mobile integration is like England without queuing

 

My first  FieldOne post, it will be the first of many as I will be using FieldOne a lot in 2016.

I have been getting to know FieldOne and going through the Learning Management System

FieldOne Learning Management System (LMS)

https://fieldone.litmos.com/self-signup/

It’s a great resource with lots of material, the slight complaint I have is some of its out of date but FieldOne is going through changes whilst the product is incorporated into the main CRM product.

Mobile

I wanted to try the mobile application, so I decided to try the Mobile Emulator.  I downloaded the mobile emulator, unzipped it.

I fired up the Mobile Emulator

Mobile Emulator

Go To Setup, fill in your details on the CRM tab

Setup mobile setup

I was getting an error

SA.NoUserData error

or

no permissions

Now What?

I am half way through my FieldOne training, I haven’t used the mobile app or emulator.  I couldn’t see any log files to help, so I was a bit stuck.

I searched the internet and even my blog didn’t come up with any solutions!! (this time)

I tried asking a question on the CRM Forum

FieldOne windows emulator SA.NoUserData error

The weakness of the forum’s is they are answered by CRM users but it means the more common your question the likely someone is to answer it.  In this case no one answered it.

FieldOne is relatively new so there are not many people who have knowledge about it, so for new products there won’t be many people who will have answers.

Neil Parkhurst to the rescue

If you are starting out with FieldOne, bookmark Neil’s blog, it’s an excellent resource for getting started with FieldOne.

http://neilparkhurst.com/category/fieldone-sky/

In his blog he had a section on installing the FieldOne Mobile App

FieldOne Sky – Install Mobile App

In here he had a tip which resolved my problem

I had a problem that my application would not run on some mobile clients, giving an error of “SA.NoUserData” or conflict with meta data. To solve these issues;

2. In CRM, on the system user form add a field called “Allow Mobile Access (Depreciated)” and set this field to “Y”.

 

I went to the user form and added the field – Allow Mobile Access (Depreciated) to the CRM user form.

Add to user field

I opened my user and set the field to Yes.

Started the emulator again and pow, I started syncing

emulator synced

You would have to set all the users you want to have mobile access to Yes

Why?

The question is why is this causing an error.  I think the problem is caused because FieldOne is being integrated into the main CRM product there are lots of fields being depreciated and there might be a few bugs caused by this whilst the code catches up and new fields used.

I think Microsoft is allowing free access to the mobile client but I’m not sure and licensing questions are always confusing and changing.  That’s my guess of the problem.

This forum has the same solution as well.

FieldOne Mobile App – sa.nouserdata

As an extra tip, check you have the latest version of the CRM mobile app

Advertisements