CRM 2011 – CRM was down after power cut

We had a power cut today in the office.  Initially you think woohooo, I can relax and have a cup of tea for the 30 minutes and then you realise you can’t make a cup of tea because the power is down.

Then you realise the only work you can do is documentation, AHGHGHGHGG

The power cut happened whilst I was at lunch having a walk, I initially thought it was either some kind of alien invasion or a particular efficient burglar because at least 6 houses had their house alarms going off.

After an hour the power came back up but the company CRM was still down and when I tried to open CRM I was getting  a rather nasty error, mentioning Priv User group and a lot of active directory messages.

This was unusual,

I check the CRM server, fine

I checked the Async services, fine

SQL Database, MSCRM_CONFIG, org database, fine

So all the obvious stuff seemed to be ok.

I then looked at the error message and noticed the localSystemAdGuid was a blank guid of all zero’s.

I was speaking out loud, mentioning active directory errors and then one of the developers said try rebooting the CRM server because if it had come up before the Domain controller then the it would affect CRM because it needs active directory.

so I rebooted the CRM server and this resolved the problem.

So there we go, tuck that piece of information and I hope it doesn’t happen to you.

One thought on “CRM 2011 – CRM was down after power cut

  1. Manu Sharma July 30, 2012 / 12:21 pm

    I am also facing the same issue but for me…..the server is not working fine even after rebooting several times….. Any Idea…why so?????


Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s